0

When I place order via clover REST API then it shows in order list in clover android device (genymotion) but when I click on this to check detail then it is giving me a popup says that "current order has been deleted" but actually that order was not deleted .

but When i place order from the clover android device via register app then it shows detail .

So please let me know that Am I doing any thing wrong or do I need to put some extra parameter or setting to see order detail placed through clover REST API ?

asked 2016-02-28 03:18:42 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

2 answers

Sort by  
0

I think you might be creating the order in test mode via the REST API (ie with the test mode property true), but your device is not in test mode. You can turn the test mode ON/OFF from the register app.

answered 2016-02-28 16:18:04 -0500

q_factor gravatar image
0

Hello, I have exactly the same problem.

I'm creating the Order via the REST API with the TestMode to false and if I open the order in Genymotion (with TestMode on and TestMode off) and I'm getting the same message: "Error - The current order has been deleted".

But If I check the order in the website application the order is correctly created.

What I'm doing wrong?

answered 2016-05-24 11:29:07 -0500

Ivan Garcia gravatar image
Comments

I have the same issue here. Any updates for it?

imentos gravatar image
imentos 2017-03-26 17:53:17 -0500

@imentos - I'm going to reach out to you via Private Message so I can replicate the behavior. If the order is malformed, it can be created but rolled back.

rachel gravatar image
rachel 2017-03-28 18:43:02 -0500